[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Rename 'svn_error_return' to 'svn_error_trace'?

From: Julian Foad <julian.foad_at_wandisco.com>
Date: Thu, 23 Jun 2011 14:19:54 +0100

On Thu, 2011-06-23 at 09:15 -0400, C. Michael Pilato wrote:
> On 06/23/2011 09:13 AM, Stefan Sperling wrote:
> > To avoid this problem we could call it svn_error_trace1, or even
> > svn_error_trace2 since it is technically an upgrade from svn_error_return :)
> Or svn_error_traced() indicating that we've traced the error to this spot
> (so far). :-)

Looking closer...

There are 695 uses of svn_error_return.

681 of them are "return svn_error_return(...);".

The other 14 are "some_err = svn_error_return(...);".

So if we're going to change the vast majority of these in any way, what
do folks feel about replacing them with


thus saving 9 characters of horizontal space?

(That's to be defined as:
#define SVN_ERR_RETURN(err) return svn_error_trace(err)

- Julian
Received on 2011-06-23 15:20:44 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.