[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Rename 'svn_error_return' to 'svn_error_trace'?

From: Greg Stein <gstein_at_gmail.com>
Date: Thu, 23 Jun 2011 13:51:48 -0400

Thanks for taking the time to do thus. Only recently did I realize that I
named the function incorrectly when I came up with it. In PoCore, I called
it pc_error_trace(), for the same reasons you suggested here.

On Jun 23, 2011 9:20 AM, "Julian Foad" <julian.foad_at_wandisco.com> wrote:
> On Thu, 2011-06-23 at 09:15 -0400, C. Michael Pilato wrote:
> > On 06/23/2011 09:13 AM, Stefan Sperling wrote:
> > > To avoid this problem we could call it svn_error_trace1, or even
> > > svn_error_trace2 since it is technically an upgrade from
svn_error_return :)
> >
> > Or svn_error_traced() indicating that we've traced the error to this
> > (so far). :-)
> Looking closer...
> There are 695 uses of svn_error_return.
> 681 of them are "return svn_error_return(...);".
> The other 14 are "some_err = svn_error_return(...);".
> So if we're going to change the vast majority of these in any way, what
> do folks feel about replacing them with


SVN_ERR() is conditional. Code typically occurs afterwards, and is executed
in the non-exceptional case. You're talking about creating a normally-used
macro that will hide this control flow change.

> thus saving 9 characters of horizontal space?

It harms readability. We don't need to save horizontal space. Last I looked,
there was a surplus in the market, so it is being given away for free.

Received on 2011-06-23 19:52:22 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.