[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN type concerns

From: Ben Collins-Sussman <sussman_at_newton.ch.collab.net>
Date: 2001-02-22 23:26:04 CET

Karl Fogel <kfogel@galois.ch.collab.net> writes:

> I'd like to hear others' thoughts on this. For what it's worth, I'm
> +0 on getting rid of svn_boolean_t. It does give a readability bonus
> imho, but it's not worth a whole new type.

I'm +1 on killing svn_boolean_t altogether.

But -- I don't want to get rid of our TRUE and FALSE defines. I think
that "return FALSE" is easier to read than "return 0", for the same
reason that I think "return SVN_NO_ERROR" is clearer than "return 0".
Zero can have different meanings in different contexts.
Received on Sat Oct 21 14:36:23 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.