Ben Collins-Sussman <firstname.lastname@example.org> writes:
> I'm +1 on killing svn_boolean_t altogether.
> But -- I don't want to get rid of our TRUE and FALSE defines. I think
> that "return FALSE" is easier to read than "return 0", for the same
> reason that I think "return SVN_NO_ERROR" is clearer than "return 0".
> Zero can have different meanings in different contexts.
That's fine -- I think that can really be left to personal preference,
since it's not actually part of the public interface. (Well, it might
be part of the documentation, but people usually read "return
non-zero" and "return true" to mean the same thing.)
Received on Sat Oct 21 14:36:23 2006
This is an archived mail posted to the Subversion Dev