> Karl Fogel <email@example.com> writes:
> > I'd like to hear others' thoughts on this. For what it's worth, I'm
> > +0 on getting rid of svn_boolean_t. It does give a readability bonus
> > imho, but it's not worth a whole new type.
> I'm +1 on killing svn_boolean_t altogether.
> But -- I don't want to get rid of our TRUE and FALSE defines. I think
> that "return FALSE" is easier to read than "return 0", for the same
> reason that I think "return SVN_NO_ERROR" is clearer than "return 0".
> Zero can have different meanings in different contexts.
I personally like my bikeshed painted TRUE and FALSE, or shades of YES
and NO if It's a bikeshed for Objective-C bikes.
But seriously, I'm also +1 on killing svn_boolean_t as well.
Received on Sat Oct 21 14:36:23 2006
This is an archived mail posted to the Subversion Dev