[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Python bindings and SVN 1.3.0-rc4

From: David James <james82_at_gmail.com>
Date: 2005-12-11 07:39:30 CET

On 12/10/05, W-Mark Kubacki <wmark@hurrikane.de> wrote:
> After having upgraded to SVN 1.3.0-rc4 I receive these errors with Trac
> (which is written in Python) and tend to believe the error is on SVN (or
> it's bindings') side:
>
> argument number 0: a 'apr_pool_t *' is expected,
> 'instance(<libsvn.core.GenericSWIGWrapper instance at 0xb4735a0c>)' is
> received

Hi Mark,

This looks like an important bug in the new 1.3.0 Python bindings in
Subversion. Could you describe which version of Trac you're using, and
how to reproduce the bug? (Do you know which function or line of code
in Trac is triggering this?)

Thanks,

David

P.S. I'm in the middle of exams in school right now, so I might not
have a chance to follow up on this right away.

--
David James -- http://www.cs.toronto.edu/~james
Received on Sun Dec 11 07:41:05 2005

This is an archived mail posted to the Subversion Users mailing list.