[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: A Different Error When Building TSVN From Source

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 25 Nov 2009 18:54:40 +0100

On 25.11.2009 17:51, Tyler Kavanaugh wrote:
>> Tyler Kavanaugh wrote:
>>> I'm getting a different error now when I try to build TortoiseSVN from sources, this time regarding an include file and a resource file that are missing. I've checked out the latest revision. I'm going to attach my complete build log, to find the errors search for the phrase "error " (that's the word error followed by a space character). I used NAnt -l:buildlog.txt setup for this particular build.
>>
>> These are certainly present in a VS 2008 *with* SP1 installation...
>> afxribbon.rc and afxcontrolbars.h are both in "Microsoft Visual Studio
>> 9.0\VC\atlmfc\include" - but note that this is for the English version
>> on my system, with the versions of afxribbon.rc for other locales an
>> additional level down in the tree.
>>
> Thanks for the info. Got that error fixed, but fixing that prompted yet another error. Here are the lines from buildlog.txt:
>
> [exec] 26>c:\Program Files\Microsoft Visual Studio 9.0\VC\include\deque(1034) : error C2039: '_Swap_adl' : is not a member of 'std'
> [exec] 26> c:\Program Files\Microsoft Visual Studio 9.0\VC\include\deque(1031) : while compiling class template member function 'void std::deque<_Ty>::_Reverse(unsigned int,unsigned int)'
> [exec] 26> with
> [exec] 26> [
> [exec] 26> _Ty=CItem
> [exec] 26> ]
> [exec] 26> c:\svn\tortoisesvn\src\tortoiseproc\RepositoryLister.h(152) : see reference to class template instantiation 'std::deque<_Ty>' being compiled
> [exec] 26> with
> [exec] 26> [
> [exec] 26> _Ty=CItem
> [exec] 26> ]
> [exec] 26>c:\Program Files\Microsoft Visual Studio 9.0\VC\include\deque(1034) : error C3861: '_Swap_adl': identifier not found
>
> Looks to me like it's an error in one of the standard include files that come packaged w/VS2008, but I have never seen this before in other things that I've compiled using VS2008 (the IDE or the command-line app).

Does this still happen if you run
nant clean binaries
?

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2424352
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-11-25 18:55:00 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.