[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 3983 - in trunk: . subversion/include subversion/libsvn_ra_svn subversion/svnserve

From: Greg Hudson <ghudson_at_MIT.EDU>
Date: 2002-12-05 04:35:04 CET

On Wed, 2002-12-04 at 12:00, brane@xbc.nu wrote:
> > I had a convention for this, which was to add "_cmd" to just the symbols
> > which had conflicts. (switch_cmd was the only one so far.) Calling
> > them ra_svn_foo means the server functions have the same names as the
> > client functions, which can be inconvenient when setting breakpoints.
>
> Ah, O.K. The other RA libs use a common prefix on the vtable functions, so in
> fact to be consistent the prefix should be svn_ra_svn__ (even on static
> functions). Personally I'd rather see those names prefixed, so that the purpose
> of the functions is obvious from the names. I'd also prefer to have the function
> names (after the prefix) the same as in ra_dav and ra_local.

My reasoning is that prefixing is for libraries; svnserve is an
application. (libsvn_ra_svn does use an ra_svn prefix on its vtable
functions.)

> > Unless we have a tree-wide style policy on this point, I'd prefer if
> > you wouldn't reformat these function declarations.

> As a matter of fact, we _do_ have a style policy, it just so happens that both
> Gregs tend to ignore it. :-)

Huh. Okay, I will go back and reformat all the other function
declarations to match. But I'm going to punt the prefix on the svnserve
command handlers.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Dec 5 04:35:57 2002

This is an archived mail posted to the Subversion Dev mailing list.