[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Homebrew SVN 1.11 not working

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 16 Jan 2019 14:54:14 -0500

On Wed, Jan 16, 2019 at 2:10 PM Branko Čibej <brane_at_apache.org> wrote:

> On 16.01.2019 15:39, Mark Phippard wrote:
> > I am trying to update my Homebrew and it looks like it wants to move
> > me from SVN 1.10 to 1.11 but it is failing. I do not recall even
> > asking it to install the Ruby bindings but perhaps I did once. I
> > thought I just had --with-java since I do need JavaHL. Any ideas?
> >
> > ==> make swig-rb EXTRA_SWIG_LDFLAGS=-L/usr/lib
> > Last 15 lines from /Users/xxxx/Library/Logs/Homebrew/subversion/14.make:
> > 2019-01-16 09:36:12 -0500
> >
> > make
> > swig-rb
> > EXTRA_SWIG_LDFLAGS=-L/usr/lib
> >
> > /bin/sh
> > "/private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/libtool"
> > --tag=CC --silent --mode=compile none -I/usr/local/opt/sqlite/include
> > -I/usr/local/opt/readline/include -I/usr/local/opt/gettext/include
> > -I/usr/local/opt/openssl/include -F/usr/local/Frameworks -isysroot
> > /Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk -DDARWIN
> > -DSIGPROCMASK_SETS_THREAD_MASK -DDARWIN_10
> >
> -I/private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/subversion/bindings/swig/ruby/libsvn_swig_ruby
> > -prefer-pic -c -o subversion/bindings/swig/ruby/svn_client.lo
> > subversion/bindings/swig/ruby/svn_client.c
> > /private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/libtool:
> > line 1760: none: command not found
> > make: *** [subversion/bindings/swig/ruby/svn_client.lo] Error 1
> >
> >
> > I do not need these so ideas could include telling me how to
> > reconfigure my install so that it does not try to build these. I only
> > need the SVN command line and JavaHL. Do not care about any other
> > language bindings.
>
>
> https://github.com/Homebrew/homebrew-core/pull/33530
>
>
I am not seeing what the solution was. The last message seemed to be about
unsetting SDKROOT but that seemed internal to Brew, not my env.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2019-01-16 20:54:36 CET

This is an archived mail posted to the Subversion Users mailing list.