[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Homebrew SVN 1.11 not working

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 16 Jan 2019 15:51:30 -0500

On Wed, Jan 16, 2019 at 2:54 PM Mark Phippard <markphip_at_gmail.com> wrote:

> On Wed, Jan 16, 2019 at 2:10 PM Branko Čibej <brane_at_apache.org> wrote:
>
>> On 16.01.2019 15:39, Mark Phippard wrote:
>> > I am trying to update my Homebrew and it looks like it wants to move
>> > me from SVN 1.10 to 1.11 but it is failing. I do not recall even
>> > asking it to install the Ruby bindings but perhaps I did once. I
>> > thought I just had --with-java since I do need JavaHL. Any ideas?
>> >
>> > ==> make swig-rb EXTRA_SWIG_LDFLAGS=-L/usr/lib
>> > Last 15 lines from /Users/xxxx/Library/Logs/Homebrew/subversion/14.make:
>> > 2019-01-16 09:36:12 -0500
>> >
>> > make
>> > swig-rb
>> > EXTRA_SWIG_LDFLAGS=-L/usr/lib
>> >
>> > /bin/sh
>> >
>> "/private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/libtool"
>> > --tag=CC --silent --mode=compile none -I/usr/local/opt/sqlite/include
>> > -I/usr/local/opt/readline/include -I/usr/local/opt/gettext/include
>> > -I/usr/local/opt/openssl/include -F/usr/local/Frameworks -isysroot
>> > /Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk -DDARWIN
>> > -DSIGPROCMASK_SETS_THREAD_MASK -DDARWIN_10
>> >
>> -I/private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/subversion/bindings/swig/ruby/libsvn_swig_ruby
>> > -prefer-pic -c -o subversion/bindings/swig/ruby/svn_client.lo
>> > subversion/bindings/swig/ruby/svn_client.c
>> > /private/tmp/subversion-20190116-34242-xgy0wo/subversion-1.11.1/libtool:
>> > line 1760: none: command not found
>> > make: *** [subversion/bindings/swig/ruby/svn_client.lo] Error 1
>> >
>> >
>> > I do not need these so ideas could include telling me how to
>> > reconfigure my install so that it does not try to build these. I only
>> > need the SVN command line and JavaHL. Do not care about any other
>> > language bindings.
>>
>>
>> https://github.com/Homebrew/homebrew-core/pull/33530
>>
>>
> I am not seeing what the solution was. The last message seemed to be
> about unsetting SDKROOT but that seemed internal to Brew, not my env.
>
>
FWIW, I decided to use $ brew edit subversion to stop the swig-rb from
trying to build, but if there is some fix I can make to my local machine
would appreciate knowing what that is for future versions. I looked through
those PR's and it seemed like all of the "fixes" were made in the build
scripts. I only have the CLT installed:

$ brew config
HOMEBREW_VERSION: 1.9.2-9-g9141b15
ORIGIN: https://github.com/Homebrew/brew.git
HEAD: 9141b1509bb44da6c0a9683733ffe4a890690d8e
Last commit: 12 hours ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 82dc586c001a22051376ecbf8076473d67089370
Core tap last commit: 9 hours ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CASK_OPTS: --appdir=/Applications
HOMEBREW_DEV_CMD_RUN: 1
HOMEBREW_LOGS: /Users/markphip/Library/Logs/Homebrew
CPU: octa-core 64-bit haswell
Homebrew Ruby: 2.3.7 =>
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
Clang: 10.0 build 1000
Git: 2.20.1 => /usr/local/bin/git
Curl: 7.54.0 => /usr/bin/curl
Java: 1.8.0_60, 1.8.0_31
macOS: 10.14.2-x86_64
CLT: 10.1.0.0.1.1539992718
Xcode: N/A

$ xcode-select -v
xcode-select version 2354.

All updates are installed.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2019-01-16 21:51:54 CET

This is an archived mail posted to the Subversion Users mailing list.