[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Compile problem

From: Madison Kelly <linux_at_alteeve.com>
Date: 2006-09-12 19:21:31 CEST

Hi all,

   This is my first post to this list, so please let me know if I am
posting the wrong questions to this list! :)

   I am trying to install Subversion 1.3.2 on my server with a dedicated
install of BerkleyDB 4.4.20 and Apache 2.2.2. I am compiling them all
into the same subdirectory: '/var/www/svn'. My './configure' for each is:

Berkley DB (in 'db-4.4.20/build_unix'):
../dist/configure --prefix=/var/www/svn/bdb

Apache2's 'apr' (in 'httpd-2.2.2/srclib/apr'):
./configure --prefix=/var/www/svn/apr

Apache2's 'apr-util' (in 'httpd-2.2.2/srclib/apr-util'):
./configure --prefix=/var/www/svn/apr-util --with-apr=/var/www/svn/apr

Apache2 proper (in 'httpd-2.2.2'):
./configure --prefix=/var/www/svn/apache2 --with-apr=/var/www/svn/apr/
--with-apr-util=/var/www/svn/apr-util/

   All of these compile and install okay (so far as I can tell). I've
been trying to install SVN with this './configure' (in 'subversion-1.3.2'):
./configure --prefix=/var/www/svn/program --with-bdb=/var/www/svn/bdb/
--with-apr=/var/www/svn/apr/ --with-apr-util=/var/www/svn/apr-util/
--with-apache=/var/www/svn/apache2/

   But I get the error:

-=-=-=-
configure: Configured to build neon 0.25.5:

   Install prefix: /var/www/svn/program
   Compiler: gcc
   XML Parser: expat
   SSL library: SSL support is not enabled
   zlib support: zlib support enabled, using -lz
   Build libraries: Shared=yes, Static=yes

neon configured properly
checking for static Apache module support... configure: error: no -
Unable to locate /var/www/svn/apache2//modules/dav/main/mod_dav.h
-=-=-=-

   I've read that I should try replacing the '--with-apache' call with
'--with-apxs=/var/www/svn/apache2/bin/apxs' as:
./configure --prefix=/var/www/svn/program
--with-apxs=/var/www/svn/apache2/bin/apxs
--with-berkeley-db=/var/www/svn/dbd

   But that causes this error:

-=-=-=-
checking for Berkeley DB 1.0.0 in /var/www/svn/bdb/lib/...
checking db1/db.h usability... no
checking db1/db.h presence... no
checking for db1/db.h... no
checking db.h usability... no
checking db.h presence... no
checking for db.h... no
checking for Berkeley DB 1 in /var/www/svn/bdb/lib/...
checking db_185.h usability... no
checking db_185.h presence... no
checking for db_185.h... no
checking for Berkeley DB... not found
configure: error: Berkeley DB not found.
configure failed for apr-util
-=-=-=-

   It complains about BerkleyDB not being there but it is. I've tried
specifying the 'lib', 'include' and 'bin' directories on the
'--with-berkeley-db=/var/www/svn/bdb/' but not love. Here is an 'ls
-lah' to show it exists:

-=-=-=-
digimer@akane:~/subversion-1.3.2$ sudo ls -lah /var/www/svn/bdb/
total 24K
drwxr-xr-x 6 root root 4.0K 2006-09-12 11:34 .
drwxr-xr-x 8 root root 4.0K 2006-09-12 10:45 ..
drwxr-xr-x 2 root root 4.0K 2006-09-12 11:34 bin
drwxr-xr-x 13 root root 4.0K 2006-09-12 11:34 docs
drwxr-xr-x 2 root root 4.0K 2006-09-12 11:34 include
drwxr-xr-x 2 root root 4.0K 2006-09-12 11:34 lib
digimer@akane:~/subversion-1.3.2$ sudo ls -lah /var/www/svn/bdb/lib/
total 3.5M
drwxr-xr-x 2 root root 4.0K 2006-09-12 11:34 .
drwxr-xr-x 6 root root 4.0K 2006-09-12 11:34 ..
-rw-r--r-- 1 root root 1.3M 2006-09-12 11:34 libdb-4.4.a
-rw-r--r-- 1 root root 812 2006-09-12 11:22 libdb-4.4.la
-rwxr-xr-x 1 root root 1005K 2006-09-12 11:22 libdb-4.4.so
lrwxrwxrwx 1 root root 12 2006-09-12 11:34 libdb-4.so -> libdb-4.4.so
-rw-r--r-- 1 root root 1.3M 2006-09-12 11:34 libdb.a
lrwxrwxrwx 1 root root 12 2006-09-12 11:34 libdb.so -> libdb-4.4.so
digimer@akane:~/subversion-1.3.2$ sudo ls -lah /var/www/svn/bdb/include/
total 144K
drwxr-xr-x 2 root root 4.0K 2006-09-12 11:34 .
drwxr-xr-x 6 root root 4.0K 2006-09-12 11:34 ..
-r--r--r-- 1 root root 36K 2006-09-12 10:48 db_cxx.h
-r--r--r-- 1 root root 96K 2006-09-12 10:48 db.h
-=-=-=-

   I want to keep *everything* SVN related under a common directory, if
at all possible, because the server it will eventually be installed on
runs other apps (inc. apache) and I want to make sure everything I do
won't impact the other server apps.

   Any help is appreciated and many thanks in advance!

Madi

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Sep 12 20:18:07 2006

This is an archived mail posted to the Subversion Users mailing list.