[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Wrong db version for src rpm rebuild

From: Kris Deugau <kdeugau_at_vianet.ca>
Date: 2005-01-06 20:32:53 CET

"Martin J. Stumpf" wrote:
> The problem is that the subversion src.rpm complains that I don't
> have db42-*-*. and the rpmbuild --rebuild fails.
>
> Any suggestions on what I can do to address this?

rpm -ivh the .src.rpm, then edit the .spec file so it uses your existing
BerkelyDB libs. I have no idea what sort of dangers might be inherent
in doing so (I've seen numerous warnings about certain BDB versions on
this list).

> I got the src rpms from summersoft.fay.ar.us in the whitebox-el-3
> directory

I would personally avoid those packages, as they replace too many things
- I've also had some rather odd errors come up attempting to rebuild
them. Check out Dag Wieers' apt/yum repo
(http://dag.wieers.com/home-made/apt/) for reasonably current Subversion
packages. Fedora is still showing 1.1.1 in the listings, but 1.1.2 is
showing for el3 and so it should be available for Fedora "Real Soon
Now".

-kgd

-- 
Get your mouse off of there!  You don't know where that email has been!
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jan 6 20:36:26 2005

This is an archived mail posted to the Subversion Users mailing list.