[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Wrong db version for src rpm rebuild

From: Martin J. Stumpf <mjs_at_jhu.edu>
Date: 2005-01-06 19:35:21 CET

Hi,
I am trying to build svn 1.1.1 from source rpms on FC2.
I have read the detailed INSTALL from the tarball and have had only one
problem albeit a very strange one. My FC2 has rpm's for bdb called
db4-*-* and the src rpm's I downloaded are called db42-*-*.

I can't rpm -e the db4 ones because so many other packages are dependent
on them. I can't install the db42 ones either because they have the same
lib names!

The problem is that the subversion src.rpm complains that I don't have
db42-*-*. and the rpmbuild --rebuild fails.

Any suggestions on what I can do to address this?

( More details if neeed below. ignore otherwise)

I got the src rpms from summersoft.fay.ar.us in the whitebox-el-3
directory because an earlier post on how to build for FC2 told the
original poster to:

"Grab the 1.1.1 source RPM from the FC3 repository and rebuild it on
FC2. You'll also need the newer swig package. You'll need to force the
swig-devel installation as the subversion-1.0.2 RPM depends on it. Once
swig-devel is built and installed, you can then build subversion-1.1.1
and install it as an update over 1.0.2. "

And I didn't want to co the repo and couldn't find a better source for
src rpms'.

Thanks

-Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jan 6 19:37:56 2005

This is an archived mail posted to the Subversion Users mailing list.