[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Verify that mod_svn is working correctly.

From: Faine, Mark <Mark.R.Faine_at_msfc.nasa.gov>
Date: 2004-11-15 21:30:32 CET

Solaris 8
Subversion 1.1.1
Apache 2.0.51
 
How can I verify that mod_dav_svn is working as it should? I have been
trying to fix a "PROPFIND request failed" error for about two weeks now. I
noticed that when I do a truss of the httpd process while attempting to
access the svn resource I get this:
 
write(9, " [ M o n N o v 1 5 ".., 102) = 102
stat("/usr/local/apache/htdocs/svn/webapps/facilities/trunk", 0xFE0077A8)
Err#2 ENOENT
lstat("/usr", 0xFE0077A8) = 0
lstat("/usr/local", 0xFE0077A8) = 0
lstat("/usr/local/apache", 0xFE0077A8) = 0
lstat("/usr/local/apache/htdocs", 0xFE0077A8) = 0
lstat("/usr/local/apache/htdocs/svn", 0xFE0077A8) Err#2 ENOENT
 
This leads me to believe that it is not correctly handing off the request to
the module but is instead looking for the repository path in the
DocumentRoot tree?
 
I'd like to verify that it is working as it should.
 
When I try to go to https://servername/svn <https://servername/svn> I get a
403 forbidden error?
 
When I try to go to https://servername/svn/webapps/facilities
<https://servername/svn/webapps/facilities> I get an XML formatted error
message that essentially says:
<m:human-readable errcode="2">Could not open the requested SVN
filesystem</m:human-readable>
 
Here what I have in my httpd.conf:
 
<Location /svn>
    DAV svn
    Order deny,allow
    Deny from all
    Allow from 192.67.109.
    SVNParentPath /export/home/repos
</Location>
 
The Apache server is running as user svn, group svn and here is the
repository directory listing:
 
/export/home/repos # ls -la
total 6
drwxrwsr-x 3 svn svn 512 Nov 15 13:44 ./
drwxr-xr-x 15 root root 512 Nov 4 14:26 ../
drwxrwsr-x 7 svn svn 512 Nov 15 13:44 webapps/
-----------------------------------
/export/home/repos/webapps # ls -la
total 18
drwxrwsr-x 7 svn svn 512 Nov 15 13:44 ./
drwxrwsr-x 3 svn svn 512 Nov 15 13:44 ../
-rw-rw-r-- 1 svn svn 379 Nov 15 13:44 README.txt
drwxrwsr-x 2 svn svn 512 Nov 15 13:44 conf/
drwxrwsr-x 2 svn svn 512 Nov 15 13:44 dav/
drwxrwsr-x 2 svn svn 512 Nov 15 13:44 db/
-r--r--r-- 1 svn svn 2 Nov 15 13:44 format
drwxrwsr-x 2 svn svn 512 Nov 15 13:44 hooks/
drwxrwsr-x 2 svn svn 512 Nov 15 13:44 locks/
 
 
I'm having a hard time believing this is a permissions error anymore.
 
Any help would be appreciated.
 
Thanks,
-Mark

 
Received on Mon Nov 15 21:31:55 2004

This is an archived mail posted to the Subversion Users mailing list.