[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Berkeley DB error while opening environment for filesystem - invalid argument

From: Max Bowsher <maxb_at_ukf.net>
Date: 2004-11-13 01:39:46 CET

Darren Martz wrote:
> Feels strange responding to my own thread.
>
> This is an old problem rooting back to OSX corrupting the database. My Mac
> is the likely culprit in this case as I do recall seeing warning messages
> about "no such string" before I backed up the database and rebuilt the
> server.
>
> http://subversion.tigris.org/issues/show_bug.cgi?id=1544
>
> Apparently someone else ran into this problem recently and it was
> recovered
> - but they did not post how it was done, and the online archives seem to
> be
> corrupted??
>
> http://subversion.tigris.org/servlets/ReadMsg?list=users&msgNo=20596
> http://subversion.tigris.org/servlets/ReadMsg?list=users&msgNo=82430 <<
> corrupted??
>
> -----Original Message-----
> From: Darren Martz [mailto:darren@shelbrook.com]
> Sent: Friday, November 12, 2004 1:24 PM
> To: 'users@subversion.tigris.org'
> Subject: RE: Berkeley DB error while opening environment for filesystem -
> invalid argument
>
> Additional Information:
>
> - The Berkeley DB library is version 4.1.25
> - On FC2, I was running the latest version of SVN as of the first week of
> Aug 2004.
> - I have been running svnserve rather than using apache
> - I have tried changing all the permissions to root, running as root and
> getting the same problem.
>
> Running "svnadmin recover" fails with the same error - invalid argument.
>
> -----Original Message-----
> From: Darren Martz [mailto:darren@shelbrook.com]
> Sent: Friday, November 12, 2004 12:10 PM
> To: users@subversion.tigris.org
> Subject: Berkeley DB error while opening environment for filesystem -
> invalid argument
>
> I recently changed my distro from FC2 to gentoo-2.6.9-r1. Unfortunately I
> cannot recall the version of subversion I was running on FC2. The version
> on
> gentoo is 1.0.9
>
> When I restored the svn data to the new system it reported the following
> error
>
> "Berkeley DB error while opening environment for filesystem -
> invalid argument"
>
> I can't find much on the problem, certainly now enough to know what to do.
>
> Any ideas?

I'm confused - how does OSX fit into a migration from FC2 to gentoo ?

Anyway, you cn probably get a bit more detailed error by changing to the
repository "db" subdirectory and running "db_recover -v". MAKE SURE NO OTHER
PROCESSES ARE ACCESSING THE REPOSITORY WHEN YOU DO THIS.

Probably the best way to sort this out would be to talk about it in realtime
on IRC.

Server: irc.freenode.net
Channel: #svn
My Nick: maxb

I tend to be around in the afternoons and evenings (my timezone is GMT).

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sat Nov 13 01:40:13 2004

This is an archived mail posted to the Subversion Users mailing list.