[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

mod_svn_authz problem (no author)

From: Christian Stocker <chregu_at_bitflux.ch>
Date: 2004-03-16 16:35:26 CET

Hi

I use subversion 1.0.1 together with apache 2.0.48 on debian/linux. I
tried to setup up user-auth with mod_svn_authz and everything works
basically fine (the access rights are applied correctly), except when I
commit something with the svn client, it's committed as "(no author)".

Any idea what's wrong:

here's my httpd.conf part:
***
<Location /repos>
   DAV svn
   SVNParentPath /var/lib/svn/
   AuthType Basic
   AuthName "Subversion Repository"
   AuthUserFile /etc/apache2/dav_svn.passwd

   AuthzSVNAccessFile /etc/apache2/dav_svn.authz

   Require valid-user
   Satisfy Any
</Location>
***

/etc/apache2/dav_svn.authz:
***
[/]
chregu = rw
****

and here's the relevant part from the logfile (stripped out some
unneeded fields for better readability):
****

x.x.x.x - - "OPTIONS /repos/test/test HTTP/1.1" 401 401
x.x.x.x - chregu "OPTIONS /repos/test/test HTTP/1.1" 200 190
x.x.x.x - - "MKACTIVITY
/repos/test/!svn/act/3fd903c1-c0d5-0310-af4b-f599ac96f762 HTTP/1.1" 201 229
x.x.x.x - chregu "PROPFIND /repos/test/test HTTP/1.1" 207 441
x.x.x.x - - "PROPFIND /repos/test/!svn/vcc/default HTTP/1.1" 207 404
x.x.x.x - - "CHECKOUT /repos/test/!svn/bln/831 HTTP/1.1" 201 245
x.x.x.x - - "PROPPATCH
/repos/test/!svn/wbl/3fd903c1-c0d5-0310-af4b-f599ac96f762/831 HTTP/1.1"
207 357
x.x.x.x - chregu "PROPFIND /repos/test/test HTTP/1.1" 207 398
x.x.x.x - chregu "CHECKOUT /repos/test/!svn/ver/831/test/dummy HTTP/1.1"
201 252
x.x.x.x - chregu "PUT
/repos/test/!svn/wrk/3fd903c1-c0d5-0310-af4b-f599ac96f762/test/dummy
HTTP/1.1" 204 -
x.x.x.x - chregu "MERGE /repos/test/test HTTP/1.1" 200 675
x.x.x.x - - "DELETE
/repos/test/!svn/act/3fd903c1-c0d5-0310-af4b-f599ac96f762 HTTP/1.1" 204
***

It does some user auth, but not everywhere... Maybe that's causing the
problem.

If I only do require valid-user without authz and satisfy any, it works
fine.

Thanks in advance for any hints.

chregu

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Mar 16 16:36:26 2004

This is an archived mail posted to the Subversion Users mailing list.