[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.6.15 Release - Icons no longer updating

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Fri, 01 Apr 2011 20:32:16 +0200

On 01.04.2011 17:28, Bob Archer wrote:

> The installer could be authored so it only upgraded from 1.6.11 and
> anything below that it tells you to uninstall the previous version
> first. That would probably resolve this. Windows installer upgrades
> are a bit tricky. If you didn't do the right thing on a previously
> released installer there is no way to fix it with a subsequent
> release. Basically, telling the user to uninstall the prev version
> first is the best way to do.
>
> I'm not sure what TSVN uses to build their installs but I could try
> to patch it to do the above if anyone is interested. But, it does
> seem like a small issue and less and less likely to hit people as
> versions march on.

We use WiX to create the msi.
The scripts are in our repository:
http://code.google.com/p/tortoisesvn/source/browse/#svn%2Ftrunk%2Fsrc%2FTortoiseSVNSetup

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2716156
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-04-01 20:32:31 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.