[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Overlay icons appear slowly or not at all

From: Lübbe Onken <l.onken_at_rac.de>
Date: 2007-05-03 16:10:53 CEST

Hi Erik,

You wrote:
> I'm encountering a real problem with overlay icons. The
> icons update very
> slowly when I traverse a working copy, and in some cases, either don't
> update after a change or disappear completely.

- Please define "very slowly". Several seconds/minutes/hours?
- How big is your working copy KB/MB/GB/TB?
- Is your WC on a network drive?

If you use explorers two pane view, the icons in the tree do not always
update correcly. This is a problem in explorer and not a TortoiseSVN
problem. The right pane should be correct after a few seconds.

> It's often seen after a merge, where several subfolders in the WC are
> updated.

As you probably know, TortoiseSVN uses an icon cache that crawls your
working copies asynchronously. After any greater local operation it may take
several seconds until the cache has recrawled the part of the wc that you
are looking at. You can try to reduce the load on the cache by defining
exclude and include paths on the "settings->overlay icons" page and by
reducing the drive types to the ones you really need.

Cheers
- Lübbe

--
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Thu May 3 16:11:00 2007

This is an archived mail posted to the TortoiseSVN Users mailing list.