[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Serious merge bug?

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Fri, 10 Oct 2008 22:41:24 +0200

Robert Dailey wrote:
> Hi,
>
> As usual, I'm not sure if this is TSVN or SVN related, so I'll start by
> reporting the issue here.
>
> Below is an error I received while trying to merge a large range of
> revisions into a feature branch from trunk. I chose the 1st of the 3
> merge options in the merge dialog. Any ideas what this could be?
>
> /Command: Merging revisions 490-673 of
> http://10.3.1.50:1337/svn/vfxrepo/vfx/trunk into C:\IT\work\jewett,
> respecting ancestry, Test Only
> Error: Working copy path
> Error: 'vfx/terrain/build/PlanetViewer/data/planets/p2/terrain_type/00 -
> Base' does
> Error: not exist in repository
> Finished!/

Hmm - just saw in another mail from you that you're using a nightly
build. I think that might be a problem: there's currently a lot of API
rewriting going on in the library (all APIs dealing with paths/urls are
split up into separate APIs for paths and urls, and that of course leads
to new bugs which are fixed daily).
I'll update to the latest svn trunk maybe this weekend.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net

Received on 2008-10-10 22:41:47 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.