[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TSVN and XnView shell extention don't play together nicely

From: Simon Large <simon.tortoisesvn_at_googlemail.com>
Date: 2007-08-03 23:44:00 CEST

On 30/07/2007, Stefan Küng <tortoisesvn@gmail.com> wrote:
> Simon Large wrote:
> > On 27/07/07, Stefan Küng <tortoisesvn@gmail.com> wrote:
> >> Yes, the context menu has changed so that it now uses the native themed
> >> UI of windows. And it doesn't use ownerdraw anymore. But it still works
> >> correct.
> >
> > Well mostly. It doesn't work on my W2K laptop when I right click on
> > the folder background. In that case I get icons and no text.
> > Strangely, in that menu TSVN is the only shellex to add to the menu,
> > so I can't blame the WinRAR shellex for messing up there.
>
> Simon, as we already mentioned before: we can't reproduce that on a
> fresh installed Win2k (ok, it's a virtual machine, but still). If you
> have some more information about how to reproduce this, maybe I can do
> something about it.

I'm struggling with this one as I have not yet found a way to *stop*
it happening. The only clue so far is that if I set OwnerdrawnMenus =
0 in the registry, then the text is fine, but of course there are
never any icons then.

Has anyone else observed this on Win2K or am I part of a nearly extinct group?

Simon

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Fri Aug 3 23:42:20 2007

This is an archived mail posted to the TortoiseSVN Dev mailing list.