[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Blame-bug (LogCache)

From: Hans-Emil Skogh <Hans-Emil.Skogh_at_tritech.se>
Date: 2007-05-23 08:52:00 CEST

Hi all!

I have been using a LogCache-enabled nightly this week. Absolutely
superb! Great work! I love it! (Ok, enough with the praise. :-) )

(Running TortoiseSVN 1.4.3, Build 9510 - 32 Bit -dev, 2007/05/21
22:50:51)

I think I have found a bug I TortoiseBlame:

It seems that only log-messages that are already present in the
log-cache will show up in tool-tips when hovering the left side pane. I
think it would be desirable to fetch all log messages in the blame-range
to the cache when opening the blame-window.

Also a bug that might be related: If I move the cursor within the left
pane (up and down) the tool-tips will work fine as long as I move from
one revision with present log message to another. However if I move the
cursor over a revision with lacking log-message, the tool-tips will stop
working completely. Only by moving the cursor over to the right pane and
back will bring back the tool-tips.
I think I have observed this bug in the past, but not been able to
reproduce it. A guess is that it might happen sometimes on slower
machines when the log-fetching lags behind... Might be worth looking
into at the same time now when it's readily reproducible.

Hans-Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Wed May 23 08:52:36 2007

This is an archived mail posted to the TortoiseSVN Dev mailing list.