[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Possible bug in Saving Authentication Information

From: Terence Cordes <Terence.Cordes_at_reuters.com>
Date: 2006-07-18 22:08:38 CEST

I downloaded and installed TortoiseSVN 1.3.5 when it became available.
Since then the "Save Authentication" option requires two logins to
complete successfully.
 
For example, I access a repository through RepoBrowser and am prompted
for login information. I enter my username and password and check the
"Save authentication" check box. Login is successful and I am taken to
the repo and directory specified, such as
http://subclipse.tigris.org/svn/subclipse/trunk/svnant. I then continue
to browse by expanding the svnant directory (clicking the '+' sign). I
am prompted again for login information. I repeat the previous login
attempt (enter username and password, check "Save authentication"
checkbox) and the svnant directory is expanded for me.
 
After this, I am never prompted for authentication information again.
It seems there is some sort of bug here as previous versions saved
authentication info after the first successful login attempt.
 
For what its worth, this occurs on repositories which are access via
http or https.
 
Regards,
 
Terry
 
Terence M. Cordes
US Regional Adoption Manager, ReutersDev.net

Reuters Messaging: terence.cordes.reuters.com@reuters.net
(t) +1.314.468.3927 | (m) +1.314.537.4290 | (f) +1.314.468.4150

Get the latest news at Reuters.com <http://www.reuters.com/>

 

To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.
Received on Tue Jul 18 22:08:56 2006

This is an archived mail posted to the TortoiseSVN Dev mailing list.