[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Re: Feature request: Warning on get lock

From: Hans-Emil Skogh <Hans-Emil.Skogh_at_tritech.se>
Date: 2006-05-02 09:03:27 CEST

> I've implemented this feature, see attached patch and screenshot.
Nice! Very nice!
> Before I commit the following needs to be discussed
> - The tooltip currently doesn't name the files which are affected which is not
> optimal. There are three alternatives: only adjust the tooltip to say "one or
> more files", list the affected files in the tooltip or add a column in the
> lock dialog. I prefer the last alternative. Comments?
The text should definitely be changed. I propose for the first sentence "Acquiring a lock for files that do not need locks will NOT prevent others from editing them in their working copies." in combination with adding a column named "Needs Lock". (The column should preferably be populated with "Yes" and "No" depending on if the svn:needs-lock property is set for that file.)
I would additionally like to propose a change for the second sentence to "To enable strict locking please permanently apply the 'svn:needs-lock' property to '*' on files that need locking.". This to address some ideas that have been expressed on the list regarding futile frobbing of the svn:needs-lock property.

> - Where do we place that warning. I've placed it in the top right corner of
> the dialog, see screenshot. But I'm not quite happy about it. Maybe we should
> resize the list control in the lock dialog, so that it can be placed above
> the "Help" button similar to the external warning in the commit dialog.
This is a tough one. I thought about it for quite some time before I submitted the original request. I think the position that you have put it in is the most aesthetically pleasing place, and that's a good thing. It might suffice if it's combined with a new "Needs Lock"-column. It would be desirable to put the warning somewhere near the "OK"-button (as you suggest), but I'm not sure how that would look, even with some resizing...

> - the warning currently uses extwarning.gif. I would prefer to rename that
> file to warning.gif and also rename IDI_EXTERNALWARNING to IDI_WARNING. The
> alternative would be to copy that file and name it lockwarning.gif but that
> redundancy is IMHO not needed.
IMHO it should be renamed and used in both places. As you say, no need for the redundancy.
Received on Tue May 2 09:03:38 2006

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.