[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Overlay icons wrong

From: Sven Brueggemann <SBrueggemann_at_gmx.net>
Date: 2005-09-02 22:53:07 CEST

Stefan Küng wrote:

>> Coming back from work, I saw that the icon of the folder I checked out
>> into is green, although "Show overlay icons recursively" is checked.
> Even after you pressed F5?

Yes.

>> To make it even more mysterious, the Icons in the WC I had reported
>> problems with on Wednesday are correct now...
>> What am I missing? What can I do to track this down?

> I really don't know. I'm close to giving up the cache and go back to our
> status handling in the shell extension.

AFAIK the cache was introduced in 1.2.0. I used that for quite a while
and never had a problem. I think it's related to the file system monitor
somehow but since nobody has reported similar problems, I'm much less than
sure.

I have several Test-WCs on my machine now and I somehow managed to make
their icons all reflect their state correctly with cleanup commands.
Let's see what the icons look tomorrow.

BTW: How can I rebuild the cache completely? Yesterday I was able to
kill TSVNCache and delete "cache" in %USERPROFILE%\Anwendungsdaten\
TSVNCache but I wasn't able to repeat that.

Kind regards

Sven

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Fri Sep 2 22:53:26 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.