[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Strange behaviour with Tortoiseproc.exe /command:commit /notempfile

From: SteveKing <steveking_at_gmx.ch>
Date: 2005-01-09 12:08:04 CET

Fernando P. Nájera Cano wrote:
[snip]
> I could understand that no files are shown, or files from another
> path... but in this case, the files are correctly shown but the first
> letters are off... It is not consistent, because I cannot infer that
> the cause of this behaviour is using relative paths.
>
> When using an absolute path it works as expected.
>
> BTW, doing some tests:
>
> * /path:c:\. gives you an empty error dialog.
> * /path:c:\.. gives you "Path 'c:\..' ends in '..', which is unsupported for this
> operation".
[snip]
>
> As you can see these results are quite distinct, but the cause is the
> same: relative paths.
[snip]

As of revision 2387, the paths we get from the commandline are first
canonicalized before we use them.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Sun Jan 9 12:08:34 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.