[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Comment bug when committing new tag in Subclipse.

From: Mark Phippard <markphip_at_gmail.com>
Date: Fri, 29 Aug 2008 09:57:29 -0400

On Fri, Aug 29, 2008 at 1:27 AM, Kim Mason <kim.mason_at_velsys.com> wrote:

> I believe that I've found a bug in Subclipse. I'm running Eclipse
> 3.4.0, and a PNG is attached showing the versions of Subclipse plugins
> installed.
>
> Anyhow, I have an Eclipse project checked out from SVN in my workspace,
> and I right clicked the project, and chose Team->Branch/Tag.
>
> I entered the details of the tag to create, entered my commit comment,
> and committed. All OK so far.
>
> However, when looking at the comment associated with the commit, it
> contains:
>
> org.tigris.subversion.subclipse.ui.comments.CommitCommentArea_at_15bbd5b
>
> This doesn't happen when I do other types of commits (i.e. committing a
> modified file through Subclipse).
>
> As a guess, I'd say that you're calling CommitCommentArea.toString(),
> but have forgotten to override Object.toString(). Perhaps...

I tried this a few different ways and could not recreate it. I test
with Eclipse 3.4 on XP just to be sure. Can you try this again a few
different ways and see if you can isolate when it happens or does not
happen?

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-08-29 15:57:40 CEST

This is an archived mail posted to the Subclipse Users mailing list.