[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-dev] Eclipse 3.1/3.2 Support

From: Eugene Kuleshov <eu_at_md.pp.ru>
Date: 2006-05-23 22:33:22 CEST

Mark Phippard wrote:

>> Why do you think it is an Eclipse issue and not something Subclipse
>> is doing wrong when creating patch?
>> Most of the time when applying Subclipse patches you need to remove
>> leading path sections in order to get matching to work.
>
> The patch is produced by Subversion and I am very confident that they are
> on spec with the unified diff format. Also, SVN patches, including this
> one, apply fine with previous Eclipse releases. Also, Eclipse landed a
> brand new Apply Patch wizard in the last milestone release of 3.2.

   Right. I recall they have introduced new feature when patch actually
applied to the workspace and not per-project.

> In this case, it just will not apply the new files at all. The changes to
> the other files are fine.

   That is weird.
   I wonder if it has anything todo with that my Subclipse projects have
different names - org.tigris.subversion.subclipse.ui vs ui. or maybe
(revision 0) marker for those files.

   regards,
   Eugene

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: dev-help@subclipse.tigris.org
Received on Tue May 23 22:33:42 2006

This is an archived mail posted to the Subclipse Dev mailing list.