[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Issue #4467 - blame youngest to oldest needs to handle SVN_INVALID_REVNUM - 1.9 blocker?

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Thu, 19 Feb 2015 18:57:04 +0000

Daniel Shahaf wrote:
> Julian Foad wrote on Tue, Feb 17, 2015 at 16:26:54 +0000:
>>  Philip wrote on IRC just now,
>>  $ svn blame -rHEAD:1000000 ../src/README
>>  svn: E235000: In file '../src/subversion/libsvn_client/blame.c'  line 497:
>> assertion failed ((frb->last_filename == NULL) || frb->include_merged_revisions)

This failure happened to me just now so I added it to the issue, and Bert is working on a fix as I speak: r1660969, r1660975.

> I am behind the libsvn_client part of this.  Am I expected to take
> ownership of these bugs?
> [...]  (I'll try to at least review the backports if I can, but if I'm
> expected to do more, just say so.)

Thank you for offering to assist, but no, I don't think you need to.

- Julian
Received on 2015-02-19 20:01:04 CET

This is an archived mail posted to the Subversion Dev mailing list.