[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.7.x backport r1643074 - load with invalid mergeinfo - resolve the veto

From: Ben Reser <ben_at_reser.org>
Date: Fri, 13 Feb 2015 10:57:22 -0800

On 2/13/15 10:07 AM, Julian Foad wrote:
> Ben, you currently have a veto recorded against 1.7.x backport r1643074 - load with invalid mergeinfo:
>
>
> * r1643074
> Don't let invalid mergeinfo stop 'svnadmin load' from working.
> Part of issue #4476 "Mergeinfo containing r0 makes svnsync and svnadmin
> dump fail".
> Justification:
> The presence of 'bad' metadata in a repository should not prevent
> backing up and restoring from a backup, given that this data does not
> make the repository totally unusable.
> Notes:
> The 'svnadmin dump' part of this issue is already approved for backport.
> The 'svnsync' part of this issue is not yet fixed.
> Branch:
> ^/subversion/branches/1.7.x-r1643074
> Votes:
> +1: julianfoad
> -1: breser (no changes on branch, attempt to merge something for this
> was mismerged on release branch in r1643189, the merge that
> was made broke swig-rb)
>

I removed my veto but it doesn't merge:

$ svn merge ^/subversion/branches/1.7.x-r1643074 .
svn: E195016: Reintegrate can only be used if revisions 1643188 through 1659644
were previously merged from
https://svn.apache.org/repos/asf/subversion/branches/1.7.x to the reintegrate
source, but this is not the case:
  subversion/branches/1.7.x-r1643074/subversion/tests/libsvn_repos/repos-test.c
    Missing ranges:
/subversion/branches/1.7.x/subversion/tests/libsvn_repos/repos-test.c:1643189,1643986
Received on 2015-02-13 19:58:51 CET

This is an archived mail posted to the Subversion Dev mailing list.