[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.7.x backport r1643074 - load with invalid mergeinfo - resolve the veto

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Fri, 13 Feb 2015 18:07:05 +0000

Ben, you currently have a veto recorded against 1.7.x backport r1643074 - load with invalid mergeinfo:

  * r1643074
   Don't let invalid mergeinfo stop 'svnadmin load' from working.
     Part of issue #4476 "Mergeinfo containing r0 makes svnsync and svnadmin
     dump fail".
     The presence of 'bad' metadata in a repository should not prevent
     backing up and restoring from a backup, given that this data does not
     make the repository totally unusable.
     The 'svnadmin dump' part of this issue is already approved for backport.
     The 'svnsync' part of this issue is not yet fixed.
     +1: julianfoad
     -1: breser (no changes on branch, attempt to merge something for this
                 was mismerged on release branch in r1643189, the merge that
                 was made broke swig-rb)

I resolved the problems (and have just synchronized the branch); could you check and at least remove your veto please if not also review it?

If anyone else can review it too, that would be great.

The same fix is proposed on 1.8.x, not vetoed, approved by me and Philip, and just needs one more vote. I have just sync'd that one's branch too.

- Julian
Received on 2015-02-13 19:07:58 CET

This is an archived mail posted to the Subversion Dev mailing list.