[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1659397 - in /subversion/trunk: TODO build/ac-macros/swig.m4

From: Branko Čibej <brane_at_wandisco.com>
Date: Fri, 13 Feb 2015 04:49:05 +0100

On 13.02.2015 01:30, Bert Huijben wrote:
>
>> -----Original Message-----
>> From: brane_at_apache.org [mailto:brane_at_apache.org]
>> Sent: donderdag 12 februari 2015 21:55
>> To: commits_at_subversion.apache.org
>> Subject: svn commit: r1659397 - in /subversion/trunk: TODO build/ac-
>> macros/swig.m4
>>
>> Author: brane
>> Date: Thu Feb 12 20:55:13 2015
>> New Revision: 1659397
>>
>> URL: http://svn.apache.org/r1659397
>> Log:
>> Do not attempt to build bindings with Swig 3.0+. Current versions
>> break the Python bindings.
>>
>> * build/ac-macros/swig.m4
>> (SVN_FIND_SWIG): Add an upper limite to supported Swig versions.
>> Do not configure bindings if the detected Swig is not suitable.
> This breaks the mac buildbot as it appears to run 3.0.2.
>
> [[
> configure:24262: checking swig version
> configure:24278: result: 3.0.2
> configure:24292: WARNING: Detected SWIG version 3.0.2
> configure:24298: WARNING: Subversion dos not support SWIG 3.0 and later
> configure:24301: WARNING: Building Python, Perl and/or Ruby bindings is disabled
> ]]
>
> I think this needs a s/dos/does/
>
> I'm surprised that we didn't see failures on this bot?
> (Is there some patch in the distribution that unbreaks swig for us?)

Maybe I just didn't look carefully enough and 3.0.2 is OK ... 3.0.3 and
later are definitely bad. I'll fix the condition.

-- Brane
Received on 2015-02-13 04:50:24 CET

This is an archived mail posted to the Subversion Dev mailing list.