[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1300197 - /subversion/trunk/subversion/include/svn_repos.h

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: Tue, 13 Mar 2012 16:00:31 -0400

On 03/13/2012 01:04 PM, Julian Foad wrote:
> C. Michael Pilato wrote:
>> On 03/13/2012 11:39 AM, julianfoad_at_apache.org wrote:
>>> * subversion/include/svn_repos.h
>>> (svn_repos_fs_get_mergeinfo): Clarify that paths start with '/'.
>>
>> Explicitly mentioned the "fspath" term?
>>
>> The paths in @a paths, and the keys of @a catalog, are fspaths (that is,
>> they start with '/').
>>
>> Or perhaps mention the term, omit its parenthesized distinguishing feature,
>> and just trust that our glossary penetration is good enough.
>>
>> There's no point in creating such terms if we don't use them.
>
> Sure, and also we could rename the parameter to 'prefix_fspath', since a
> clue in the function prototype is even more helpful than in the doc
> string.

Agreed!

> But I also thought we might want to relax the function to allow either
> fspaths or relpaths (maybe requiring the prefix kind to match the cat
> keys kind, maybe not). Specifically, I've written some uncommitted code
> which needs this function to be so relaxed, and also I noticed that the
> complementary 'add_prefix' function seems to be so relaxed as well.
> Didn't want to delay the commit because of such thoughts.

Fair 'nuff.

-- 
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on 2012-03-13 21:01:10 CET

This is an archived mail posted to the Subversion Dev mailing list.