Re: svn commit: r1300197 - /subversion/trunk/subversion/include/svn_repos.h
From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Tue, 13 Mar 2012 17:04:55 +0000 (GMT)
[CC -= commits@]
C. Michael Pilato wrote:
Sure, and also we could rename the parameter to 'prefix_fspath', since a clue in the function prototype is even more helpful than in the doc string.
But I also thought we might want to relax the function to allow either fspaths or relpaths (maybe requiring the prefix kind to match the cat keys kind, maybe not). Specifically, I've written some uncommitted code which needs this function to be so relaxed, and also I noticed that the complementary 'add_prefix' function seems to be so relaxed as well. Didn't want to delay the commit because of such thoughts.
This is an archived mail posted to the Subversion Dev mailing list.