[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Rename 'svn_error_return' to 'svn_error_trace'?

From: Julian Foad <julian.foad_at_wandisco.com>
Date: Thu, 23 Jun 2011 19:17:49 +0100

Greg Stein wrote:
> Thanks for taking the time to do thus. Only recently did I realize that I
> named the function incorrectly when I came up with it. In PoCore, I called
> it pc_error_trace(), for the same reasons you suggested here.

OK, I'll do it.

Does anyone want me to leave "svn_error_return" as an alias for the time
being, to be removed before 1.7.0, to avoid gratuitous failures with
developers' local mods and when applying patches over the next few days?
I'll happily do so if anyone says "yes" (it's very little extra work),
but if no-one says "yes" then I won't.

> > There are 695 uses of svn_error_return.
> >
> > 681 of them are "return svn_error_return(...);".
> >
> > The other 14 are "some_err = svn_error_return(...);".
> >
> > So if we're going to change the vast majority of these in any way, what
> > do folks feel about replacing them with
> >
> No.
> SVN_ERR() is conditional. Code typically occurs afterwards, and is executed
> in the non-exceptional case. You're talking about creating a normally-used
> macro that will hide this control flow change.

OK, good to hear your input.

- Julian

> >
> > thus saving 9 characters of horizontal space?
> It harms readability. We don't need to save horizontal space. Last I looked,
> there was a surplus in the market, so it is being given away for free.
> -g
Received on 2011-06-23 20:18:30 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.