On Thu, Jun 23, 2011 at 09:59:48AM -0400, C. Michael Pilato wrote:
> On 06/23/2011 09:33 AM, stsp_at_apache.org wrote:
> > Author: stsp
> > Date: Thu Jun 23 13:33:57 2011
> > New Revision: 1138871
> > URL: http://svn.apache.org/viewvc?rev=1138871&view=rev
> > Log:
> > As part of internal API cleanup, and in the name of code clarity,
> > rename svn_wc__db_status_absent to svn_wc__db_status_unauthz (not
> > authorized), because this is what 'absent' really means. Now there
> > is less potential for confusing 'absent' with 'not-present' and 'excluded'.
> I disagree with this change. The working copy does not -- and cannot --
> know why the server has chosen to omit a child from a directory. Maybe it's
> because of authz. Maybe it's because of some as-yet-developed obliterate
> side-effect. Who knows? The point is, the decision was the server's to
> make, and the client isn't privy to the reasoning behind it. That's why we
> used something as generic as "absent" in the first place.
> Now, I'm fine with using something other than "absent" ("omitted",
> "withheld", ...), but -1 on any terminology that allows the WC to presume to
> know what it simply cannot.
Julian also suggested "server-excluded". Would that work?
It should be more descriptive than "absent" and sufficiently different
from "not-present" and "excluded". None of the alternatives you suggest
carry more information than "absent", nor are they sufficiently
different from the other terms.
Received on 2011-06-23 16:10:23 CEST