On 06/23/2011 09:33 AM, stsp_at_apache.org wrote:
> Author: stsp
> Date: Thu Jun 23 13:33:57 2011
> New Revision: 1138871
> URL: http://svn.apache.org/viewvc?rev=1138871&view=rev
> As part of internal API cleanup, and in the name of code clarity,
> rename svn_wc__db_status_absent to svn_wc__db_status_unauthz (not
> authorized), because this is what 'absent' really means. Now there
> is less potential for confusing 'absent' with 'not-present' and 'excluded'.
I disagree with this change. The working copy does not -- and cannot --
know why the server has chosen to omit a child from a directory. Maybe it's
because of authz. Maybe it's because of some as-yet-developed obliterate
side-effect. Who knows? The point is, the decision was the server's to
make, and the client isn't privy to the reasoning behind it. That's why we
used something as generic as "absent" in the first place.
Now, I'm fine with using something other than "absent" ("omitted",
"withheld", ...), but -1 on any terminology that allows the WC to presume to
know what it simply cannot.
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet <> www.collab.net <> Distributed Development On Demand
Received on 2011-06-23 16:00:25 CEST