[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Rename 'svn_error_return' to 'svn_error_trace'?

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 23 Jun 2011 15:13:44 +0200

On Thu, Jun 23, 2011 at 08:57:28AM -0400, C. Michael Pilato wrote:
> Omigosh. +1. I, too, know we're well into bikeshed territory here, but if
> we're going to paint our sheds anyway, why use only a clear-coat stain
> ("return svn_error_return(...)")? Use a color that says something!

Yes, +1!

> "svn_error_trace" is a fine choice of a name. Just a pity that it's a
> character shorter than the existing name, though, as far as the
> global-search-and-replace goes. Mmm... indentation... :-(

To avoid this problem we could call it svn_error_trace1, or even
svn_error_trace2 since it is technically an upgrade from svn_error_return :)
Received on 2011-06-23 15:14:23 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.