[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r946713 - in /subversion/trunk/subversion/libsvn_wc: adm_files.c adm_files.h update_editor.c

From: Greg Stein <gstein_at_gmail.com>
Date: Thu, 20 May 2010 13:40:36 -0400

On Thu, May 20, 2010 at 13:04, <julianfoad_at_apache.org> wrote:
> Author: julianfoad
> Date: Thu May 20 17:04:56 2010
> New Revision: 946713
>
> URL: http://svn.apache.org/viewvc?rev=946713&view=rev
> Log:
> Move a function to where it can be shared, and give it a better name.
>
> * subversion/libsvn_wc/adm_files.h,
>  subversion/libsvn_wc/adm_files.c
>  (svn_wc__get_ultimate_base_md5_checksum): New function, based on

More naming terminology? When I see this, it makes me ask, "What does
"ultimate" mean?" The docstring doesn't make it clear why this new
term is present.

The underlying db function is svn_wc__db_base_get_info(), so why
wouldn't this simply be svn_wc__base_get_md5_checksum() ?

>...

Cheers,
-g
Received on 2010-05-20 19:41:10 CEST

This is an archived mail posted to the Subversion Dev mailing list.