On Thu, 2010-05-20, Greg Stein wrote:
> On Thu, May 20, 2010 at 13:04, <julianfoad_at_apache.org> wrote:
> > Author: julianfoad
> > Date: Thu May 20 17:04:56 2010
> > New Revision: 946713
> > URL: http://svn.apache.org/viewvc?rev=946713&view=rev
> > Log:
> > Move a function to where it can be shared, and give it a better name.
> > * subversion/libsvn_wc/adm_files.h,
> > subversion/libsvn_wc/adm_files.c
> > (svn_wc__get_ultimate_base_md5_checksum): New function, based on
> More naming terminology? When I see this, it makes me ask, "What does
> "ultimate" mean?" The docstring doesn't make it clear why this new
> term is present.
> The underlying db function is svn_wc__db_base_get_info(), so why
> wouldn't this simply be svn_wc__base_get_md5_checksum() ?
Because I'm working on a WC-1 legacy code base in which the term "text
base" usually means something like
"the copied base if the file is replaced with a copy,
else nothing if replaced by a simple add,
else the - uh, how shall we say it? - "ultimate" base,
therefore I can't simply use the word "base" and expect that to be
clear. I'm trying to change the names in two steps, from the old
(inconsistent and unclear) names, through some intermediate names of
which this is one, then to some final perfect naming.
I'll post separately about naming.
Received on 2010-05-21 12:18:28 CEST