[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bump minimal APR version

From: Mark Phippard <markphip_at_gmail.com>
Date: Thu, 11 Mar 2010 10:31:45 -0500

On Thu, Mar 11, 2010 at 10:25 AM, Hyrum K. Wright
<hyrum_wright_at_mail.utexas.edu> wrote:

> But does httpd-2.0.x *require* apr 0.9.x?  For a long time, Subversion shipped with apr 0.9.x, but
> we've always been compatible with the 1.x series.  I wonder if http 2.0.x is similar.

Yes it requires 0.9.x.

> My general thoughts on stuff like this is that folks want a newer version of Subversion, they may > need to upgrade their dependencies.  If they are unable or unwilling to do so, then they will just
> have to stick with the older version of Subversion.  If these means that somebody on a RHEL 4.0
> box who is stuck using httpd 2.0.x can't run Subversion 1.7 without more work, tough.  I suspect
> these folks are a relatively small number of our usership.

I don't get this. We are willing to do things like require Python 2.4
(which we did in 1.6) and consider requiring APR 1.3. These sorts of
things impact a significant number of our users and really bring us as
developers only modest benefits in terms of making our lives easier.

Yet, we force ourselves to jump through hoops keeping our libsvn_wc
API compatible, probably tripling the amount of time it takes to
rewrite it. When the impact on our users if we just said screw it and
broke the compatibility would probably be minimal. After all, the API
sucks how many people wrote custom tools to this level of the API as
opposed to libsvn_client? And most of those users would probably live
with the notion that at least their own code would get easier when
they had to update it for a new library.

Anyway, I know we are not going to change this approach, I just think
we are our own worst enemy some times.

Mark Phippard
Received on 2010-03-11 16:33:20 CET

This is an archived mail posted to the Subversion Dev mailing list.