[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bump minimal APR version

From: Jeremy Whitlock <jcscoobyrs_at_gmail.com>
Date: Thu, 11 Mar 2010 08:48:49 -0700

>> My general thoughts on stuff like this is that folks want a newer version of Subversion, they may > need to upgrade their dependencies. If they are unable or unwilling to do so, then they will just
>> have to stick with the older version of Subversion. If these means that somebody on a RHEL 4.0
>> box who is stuck using httpd 2.0.x can't run Subversion 1.7 without more work, tough. I suspect
>> these folks are a relatively small number of our usership.
>
> I don't get this. We are willing to do things like require Python 2.4
> (which we did in 1.6) and consider requiring APR 1.3. These sorts of
> things impact a significant number of our users and really bring us as
> developers only modest benefits in terms of making our lives easier.

I don't know man. Even Python 2.4 is almost 5 years old already and just "upgrading" it came with many things that just made life easier, like subprocess for example. Apache 2.0 is almost 11 years old. Finally, not only is RHEL4 5 years old but it's reached its EOL. As maintainer of one of the more complete binaries for OS X, I know how difficult it is to support such old dependencies and libraries, let alone find environment old enough to even build on those older environments. That being said, I've already dropped Tiger support from my binary, which was using Python 2.3/APR 0.9.x/httpd 2.0.x, and I've had no push back at all from any users at this point. Just something to think about.

Jeremy Whitlock <jcscoobyrs_at_gmail.com>
http://www.thoughtspark.org
Received on 2010-03-11 16:50:30 CET

This is an archived mail posted to the Subversion Dev mailing list.