[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bump minimal APR version

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: Thu, 11 Mar 2010 09:25:41 -0600

On Mar 10, 2010, at 7:05 PM, Greg Stein wrote:

> On Wed, Mar 10, 2010 at 13:34, Hyrum K. Wright
> <hyrum_wright_at_mail.utexas.edu> wrote:
>> I'd like to propose that we bump the minimal APR version from the current 0.9.7 to something a bit more modern, say 1.3.0.
>> 1.3.0 was released in June 2008, and we are already conditionally using parts of it. In fact, in the 1.6.x series, we've even shipped APR/APR-util 1.3.x in the deps tarball. Neither of these practices have caused consternation among our users, who almost exclusively use the system-provided APR (or the one compiled into their client).
>> We are currently planning on making ra_serf the default dav provider in Subversion 1.7. As ra_serf depends on serf, and the latter requires APR at least 1.x, I think it reasonable that we bump our minimal required APR version as well.
>> In that past, I recall some pressing reason for still keeping 0.9.7 as the minimal required version, but I don't recall what those arguments were, nor do I think they are still relevant.
>> Thoughts?
> As I said on IRC, I believe the requirement is caused by httpd 2.0.x
> requiring APR 0.9.x. If we bump the requirement, then mod_dav_svn
> could not be loaded into httpd 2.0.x. I'm guessing there are plenty of
> 2.0 servers out there.
> Ah. Just downloaded the 2.0.63 httpd tarball and verified it comes with 0.9.x.

But does httpd-2.0.x *require* apr 0.9.x? For a long time, Subversion shipped with apr 0.9.x, but we've always been compatible with the 1.x series. I wonder if http 2.0.x is similar.

My general thoughts on stuff like this is that folks want a newer version of Subversion, they may need to upgrade their dependencies. If they are unable or unwilling to do so, then they will just have to stick with the older version of Subversion. If these means that somebody on a RHEL 4.0 box who is stuck using httpd 2.0.x can't run Subversion 1.7 without more work, tough. I suspect these folks are a relatively small number of our usership.

Received on 2010-03-11 16:27:24 CET

This is an archived mail posted to the Subversion Dev mailing list.