On Wed, Mar 10, 2010 at 13:34, Hyrum K. Wright
> I'd like to propose that we bump the minimal APR version from the current 0.9.7 to something a bit more modern, say 1.3.0.
> 1.3.0 was released in June 2008, and we are already conditionally using parts of it. In fact, in the 1.6.x series, we've even shipped APR/APR-util 1.3.x in the deps tarball. Neither of these practices have caused consternation among our users, who almost exclusively use the system-provided APR (or the one compiled into their client).
> We are currently planning on making ra_serf the default dav provider in Subversion 1.7. As ra_serf depends on serf, and the latter requires APR at least 1.x, I think it reasonable that we bump our minimal required APR version as well.
> In that past, I recall some pressing reason for still keeping 0.9.7 as the minimal required version, but I don't recall what those arguments were, nor do I think they are still relevant.
As I said on IRC, I believe the requirement is caused by httpd 2.0.x
requiring APR 0.9.x. If we bump the requirement, then mod_dav_svn
could not be loaded into httpd 2.0.x. I'm guessing there are plenty of
2.0 servers out there.
Ah. Just downloaded the 2.0.63 httpd tarball and verified it comes with 0.9.x.
Received on 2010-03-11 02:05:38 CET