[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[RFC] [PATCH] Raise minimal required version of Neon to 0.27

From: Arfrever Frehtes Taifersar Arahesis <arfrever.fta_at_gmail.com>
Date: Sun, 7 Sep 2008 00:48:35 +0200

I would like to suggest to raise minimal required version of Neon to 0.27.
When Subversion 1.6 is released, Neon 0.26 will be very old and rather
nobody will try to use Subversion 1.6 with such old versions of Neon.
(r21480 removed support for Neon 0.24.)

[[[
Raise minimal required version of Neon to 0.27.

* configure.ac
  (NEON_ALLOWED_LIST): Delete 0.25.* and 0.26.* from the list.

* build/ac-macros/neon.m4
  (SVN_LIB_NEON, SVN_NEON_CONFIG): Don't define SVN_NEON_0_26 and
   SVN_NEON_0_27.

* build/generator/gen_win.py
  (GeneratorBase.parse_options): Set self.neon_ver to 27000.
  (WinGeneratorBase.get_win_defines): Don't define SVN_NEON_0_26 and
   SVN_NEON_0_27.
  (WinGeneratorBase._find_neon): Print a warning when Neon older than 0.27.0
   is found.

* subversion/libsvn_ra_neon/session.c
  (get_server_settings, ra_neon_neonprogress, svn_ra_neon__open):
* subversion/libsvn_ra_neon/util.c
  (generate_error):
* subversion/libsvn_subr/config_file.c
  (svn_config_ensure): Make SVN_NEON_0_2[67] part unconditional. Delete
   !SVN_NEON_0_2[67] part.

* INSTALL
  (Dependencies in Detail, Building the Latest Source under Windows): Update.
]]]

-- 
Arfrever Frehtes Taifersar Arahesis

Received on 2008-09-07 00:52:38 CEST

This is an archived mail posted to the Subversion Dev mailing list.