[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r28951 - in trunk: notes subversion/include subversion/libsvn_client subversion/svn subversion/tests/cmdline

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: Fri, 18 Jan 2008 17:09:11 -0500

Hyrum K. Wright wrote:
> cmpilato_at_tigris.org wrote:
>> Author: cmpilato
>> Date: Fri Jan 18 11:18:53 2008
>> New Revision: 28951
>>
>> Log:
>> Finish the --changelist feature revamp for the propset, propget,
>> proplist, and propdel subcommands.
>>
>> * subversion/include/svn_client.h
>> (svn_client_propset3, svn_client_propget4, svn_client_proplist3):
>> Add 'changelists' parameter.
>> (svn_client_propset2, svn_client_propget3, svn_client_proplist2):
>> Update docstrings.
> ...
>> Modified: trunk/subversion/include/svn_client.h
>> URL: http://svn.collab.net/viewvc/svn/trunk/subversion/include/svn_client.h?pathrev=28951&r1=28950&r2=28951
>> ==============================================================================
>> --- trunk/subversion/include/svn_client.h (original)
>> +++ trunk/subversion/include/svn_client.h Fri Jan 18 11:18:53 2008
>> @@ -3154,6 +3154,12 @@
>> * SVN_ERR_BAD_MIME_TYPE (if @a propname is "svn:mime-type", but @a
>> * propval is not a valid mime-type).
>> *
>> + * @a changelists is an array of <tt>const char *</tt> changelist
>> + * names, used as a restrictive filter on items whose properties are
>> + * set; that is, don't set properties on any item unless it's a member
>> + * of one of those changelists. If @a changelists is empty (or
>> + * altogether @c NULL), no changelist filtering occurs.
>> + *
>> * If @a ctx->cancel_func is non-NULL, invoke it passing @a
>> * ctx->cancel_baton at various places during the operation.
>> *
>> @@ -3169,14 +3175,16 @@
>> svn_depth_t depth,
>> svn_boolean_t skip_checks,
>> svn_revnum_t base_revision_for_url,
>> + const apr_array_header_t *changelists,
>> svn_client_ctx_t *ctx,
>> apr_pool_t *pool);
>
> <bikeshed color="topaz">
> In updating the JavaHL wrappers, I noticed that almost every other
> changelist api has the changelist parameter immediately after the depth
> parameter, before any boolean flags. Any reason not to do that here?
> </bikeshed>

I've been pretty consistent about making 'changelists' be the last variable
before function-specific callbacks or ctx (when no such callbacks exist).
If 'depth' is bouncing around, I've not noticed.

-- 
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on 2008-01-18 23:16:23 CET

This is an archived mail posted to the Subversion Dev mailing list.