[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: (warning: bikeshed) Naming mergeinfo.db.

From: Eric Gillespie <epg_at_pretzelnet.org>
Date: 2007-11-21 23:03:57 CET

"David Glasser" <glasser@davidglasser.net> writes:

> While there are aesthetic reasons for this change, I'm not sure that
> the argument of "we'll have more indexes so they should all go in
> index.sqlite" makes sense. I just added a second index to
> indexes.sqlite (for the node-origins query); however, this data and
> the mergeinfo are pretty independent, have different caching
> semantics, and won't be joined against each other, so in the interests
> of throughput (because sqlite3 locks entire db files, not tables), I
> propose we revert r26947 and keep mergeinfo.sqlite and
> node-origins.sqlite in separate files.

+1, please do it. These operations have no business at all
blocking each other.

Eric Gillespie <*> epg@pretzelnet.org

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 21 23:04:37 2007

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.