[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: (warning: bikeshed) Naming mergeinfo.db.

From: David Glasser <glasser_at_davidglasser.net>
Date: 2007-11-21 23:10:03 CET

On Nov 21, 2007 5:03 PM, Eric Gillespie <epg@pretzelnet.org> wrote:
> "David Glasser" <glasser@davidglasser.net> writes:
>
> > While there are aesthetic reasons for this change, I'm not sure that
> > the argument of "we'll have more indexes so they should all go in
> > index.sqlite" makes sense. I just added a second index to
> > indexes.sqlite (for the node-origins query); however, this data and
> > the mergeinfo are pretty independent, have different caching
> > semantics, and won't be joined against each other, so in the interests
> > of throughput (because sqlite3 locks entire db files, not tables), I
> > propose we revert r26947 and keep mergeinfo.sqlite and
> > node-origins.sqlite in separate files.
>
> +1, please do it. These operations have no business at all
> blocking each other.

My head is deep in some other code right now, and it's not 100%
trivial (it'll require changing some of the sqlite util functions to
take extra params, etc), but I'll do it on Monday at the latest.

--dave

-- 
David Glasser | glasser_at_davidglasser.net | http://www.davidglasser.net/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 21 23:10:56 2007

This is an archived mail posted to the Subversion Dev mailing list.