[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: (warning: bikeshed) Naming mergeinfo.db.

From: David Glasser <glasser_at_davidglasser.net>
Date: 2007-11-19 17:09:10 CET

On Sep 19, 2007 12:19 PM, Malcolm Rowe <malcolm-svn-dev@farside.org.uk> wrote:
> Secondly, I wonder what we'll do when we want to add more derived
> information to the filesystem (e.g. someone [I forget who, sorry] showed
> a proof-of-concept SQLite property indexer a while back). Will we
> create another SQLite database?
>
> So, I propose we rename mergeinfo.db to something more generic: say,
> indexes.db. You can all lynch me now.

While there are aesthetic reasons for this change, I'm not sure that
the argument of "we'll have more indexes so they should all go in
index.sqlite" makes sense. I just added a second index to
indexes.sqlite (for the node-origins query); however, this data and
the mergeinfo are pretty independent, have different caching
semantics, and won't be joined against each other, so in the interests
of throughput (because sqlite3 locks entire db files, not tables), I
propose we revert r26947 and keep mergeinfo.sqlite and
node-origins.sqlite in separate files.

--dave

-- 
David Glasser | glasser_at_davidglasser.net | http://www.davidglasser.net/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Nov 19 17:09:33 2007

This is an archived mail posted to the Subversion Dev mailing list.