[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

FSFS corrupted revfiles && APR minimal version?

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2007-11-06 22:37:44 CET

I just checked the APR site and the latest versions are 1.2.11 and
0.9.16. While checking their CHANGES files (respectively at
http://www.apache.org/dist/apr/CHANGES-APR-1.2 and
http://www.apache.org/dist/apr/CHANGES-APR-0.9), I noticed that there
are some fixes which are at least interesting for us. My question is:
Could these be related to the FSFS revfile corruptions we have seen
and if so, should we up our requirements?

1) "Fix file pointer position calculation in apr_file_writev()." (apr
0.9.14 and 1.2.9)
2) "Fix thread safety of assorted file_io functions" (apr 0.9.14 and 1.2.9)

Does anybody have an answer to these questions?

bye,

Erik.

PS:

Next to the 2 above, there's one for OS/X which we might want to
require to prevent BFI (Bad First Impression):

- "Define OS/X filesystem encoding as UTF-8" (apr 0.9.15 and 1.2.10)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Nov 6 22:38:16 2007

This is an archived mail posted to the Subversion Dev mailing list.