[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Correct two doc strings and rename a local type for clarity.

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2006-03-13 14:29:50 CET

Malcolm Rowe wrote:
> +1, looks good, only one extra comment below. It's nice to have someone
> else looking at diff, thanks Julian!

Ugh. I've been meaning to for years, and it's because you are interested that
I'm having another go now. It's making my head spin. It really is time we
generalised this code to get rid of lots of the special cases (e.g. that
repo-repos diff supports both single-object-at-two-revisions and
two-independent-objects modes, whereas wc-wc diff doesn't).

>>@@ -2457,11 +2358,6 @@ do_diff_summarize_peg(const struct diff_
>> Svn_client_diff3() is the single entry point for all of the diff
> "svn_client_diff3()"? Even though it is as the start of the sentence.

Oh yes, I might as well change that while I'm at it.

>> operations, and will be in charge of examining the inputs and
> "is in charge"? Or perhaps drop everything after the comma - it doesn't
> add much.

Yes. Now I look at it, the first half of the sentence isn't true any more
(there are multiple entry points) so I'll drop the whole thing.

Thanks for the review.

- Julian

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Mar 13 14:32:19 2006

This is an archived mail posted to the Subversion Dev mailing list.